WooCommerce products not showing on your Shop page?

Published 25 Oct 2015 in Plugins, Uncategorized, WordPress by ZigPress

Here’s a quick tip for those developing a WooCommerce-based website, particularly if it’s your first time.

Sometimes, after installing WooCommerce into your WordPress installation, and adding a product, you’ll find that the product displays fine if you click ‘View Product‘ on the product edit screen, but if you go to your ‘Shop‘ page, nothing shows.

The solution is to go to the Admin > Settings > Permalinks page and click the ‘Save Changes‘ button. This ensures that WordPress is told about the extra permalink URL structures needed for WooCommerce.

This makes sense if you think about it, since WooCommerce products are simply a WordPress custom post type, and it’s usually necessary to save permalinks after adding a new custom post type in your theme.

44 Comments

  1. On 26 Oct 2015 at 11:02, Premchand said:

    nice sir

  2. On 17 Nov 2015 at 17:58, Genvideos said:

    nice work

  3. On 25 Nov 2015 at 08:22, Jay said:

    Hi, its a really useful post on showing on your Shop page. Thank you for sharing such a good article and keep good work on n keep sharing such great information.

  4. On 10 Jan 2016 at 15:40, Ekramul Haque said:

    Good

  5. On 17 Sep 2016 at 23:40, Duan said:

    Im having this precise problem but it persists after every ‘fix’ I try. I’ve renamed the .htaccess file and re-built them by saving changes on the permalinks page. I’ve also deleted _old_slugs in the database. When i access the url to the page set as the product base page in woocommerce, my site displays a blank page and the title in the browser tab changes to Posts like its redirecting. Is this an issue to take up the woocommerce developers or my theme developers? Any help is greatly appreciated.

    Regards,
    Duan

  6. On 18 Sep 2016 at 15:01, ZigPress said:

    Disable all your plugins except WC and switch theme to a new install of the official Storefront theme, switch off any child theme, refresh permalinks and see what happens. You could even try switching theme back to a default WP one like TwentyFourteen. If you get to a point where things are OK, you know that one of the things you disabled has caused the problem, so re-enable them one by one and keep retesting. You should be able to narrow down the problem to one particular thing in the end.

  7. On 02 Nov 2016 at 23:20, Duan said:

    I’ve narrowed it down to one plugin; Jetpack. My ‘/shop’ page loads fine, until I link Jetpack to wordpress.com, then the page goes haywire. What do I do now?

  8. On 10 Dec 2016 at 18:33, José Rivas said:

    God!! thank you man, I was really desperate!

  9. On 12 Jan 2017 at 21:35, MakeOnlineShop said:

    Any more solutions ?

    I tried all already and still no products on /shop page !

    Thank you.

  10. On 17 Jan 2017 at 18:28, Shin Nihonto said:

    Nice and simple, thank you so much!

  11. On 19 Feb 2017 at 13:19, Sophie said:

    You rock !

  12. On 30 Apr 2017 at 23:15, nigimart said:

    Am having same problem. When I click on any product category. Woo commerce probably shows 2 products out of 90.

  13. On 06 May 2017 at 17:54, Leigh said:

    I have the same problem. I can see the product when im logged in, but when i view my site when im not logged in, its not in the product category. I can access it directly via its link though. I have tried re-saving the permalink, but that doesnt help.

  14. On 23 May 2017 at 15:06, Simon Tinning said:

    Brilliant! Searching for days for a solution. So grateful..a big thanks. You are a star.

  15. On 02 Jun 2017 at 23:02, Kristina Toto said:

    None of this helped me. I can only see when signed in as admin no one else can wholesale no one.

  16. On 12 Jun 2017 at 15:30, avidnie said:

    my woo commerce shop page doesn’t display any product image on mobile phone..on computer its fine…someone help please

  17. On 22 Jun 2017 at 21:24, Buba said:

    THANK YOU!!!

  18. On 04 Jul 2017 at 20:55, francisco j cuellar said:

    you dont need to save it, just load that page. Woocommerce is too dumb to figure it out

  19. On 19 Jul 2017 at 14:23, Pius said:

    I followed your step above and still the same problem. Can you be more specific with what should be checked on the permanent link page? The exact problem is that when logged in as administrator I get to see the products on the page but when no user is logged in the shop page is blank. All products are not set to hidden.

  20. On 21 Jul 2017 at 10:57, Devesh said:

    Done what is being said here, still persist the issue. Also checked the visibility of the product, seems fine.
    I dont know what to do now? May be apache restart or something?
    Can you please help!
    Thanks in advance!

  21. On 26 Jul 2017 at 22:24, david crocker said:

    same here…my PC shows the Shop items fine but my mobile doesnt! why is this please? can anyone help?

  22. On 28 Sep 2017 at 11:36, dave said:

    The problem i am having is products not showing on the shop page..I have noticed that when i switch the static page to shop and home page to post, the shop page appears on the main domain but not shop extension and the home page disappears..If i don’t change anything, the home page is fine but the shop link goes to the standard blog page that appears when you first install word press..I am using shop keeper theme..I must have done something wrong but can’t figure out what..any suggestions would be greatly appreciated..

  23. On 04 Nov 2017 at 10:09, Barry said:

    Thank you for the tip, it works!

    I selected a different Product Permalink Setting from the default one I was using and saved changes with that first, then I went back in and reselecte the default setting and saved back out again—that fixed it for me.

  24. On 17 Nov 2017 at 15:13, Plamen said:

    First, make a new page and then change the directory in which woocommerce sees the Shop page. Woocommerce -> Settings -> Products -> Display -> Shop page (set the new page). It worked for me.

  25. On 19 Nov 2017 at 08:52, Drew Germaine said:

    It was BuddyPress. Go to the ‘Pages’ option and select ‘none’ for all directories – members, user groups, etc, etc. Fixed Instantly.

  26. On 27 Nov 2017 at 09:34, Kiros said:

    Thank you =)

  27. On 12 Jan 2018 at 20:00, Jamie said:

    None of these “solutions” worked, in fact it made my shop even worse! Not only does the “shop” page not show anything, now when I am on my homepage, when I click on a category, it also does not show anything! Trying the permalink “fix” broke my categories now. I tried deleting the page, then going into WooCommerce settings and having it re-create the missing pages and it still didn’t work. I would SO appreciate some help here!

  28. On 24 Jan 2018 at 03:54, Vivian said:

    I deactivated and deleted the WooCommerce Plug-in and then re-installed and activated the WooCommerce plug-in again and all of my products were still there with all products now properly showing.

  29. On 25 Jan 2018 at 15:36, Mondoman said:

    The problem I’m having is that occasionally the individual product pages come up blank. Checking page source shows incomplete html. When this happens its across all users and browsers and all products. Obviously server side, not browser or connection. The way to fix it is to go back to the shop page and add any item to the cart. Then everything works for everyone… until it happens again. Fortunately it’s not every day. But I would like to figure out what is causing it and find a better way to fix it.

  30. On 05 Apr 2018 at 18:41, Melissa said:

    Wordpress just updated to the newest version and has caused problems with the items in one of the categories not showing up. I’ve saved the changes to the permalinks, deactivated as many plugins as possible and yet only half of the products show up. As soon as I click on the category, I can see a bar with the results bar, but it immediately disappears. What’s going on?

  31. On 06 Apr 2018 at 11:42, ZigPress said:

    That sounds like a different problem from the one described in my post. I’d suggest trying WooCommerce support.

  32. On 11 May 2018 at 18:57, Benji West said:

    this didnt work for me.

    what did work was

    woo commerce > settings > products > shop page

    Moved the shop page to another page – eg demos – then move it back to shop.

    Then magically appeared after hard refresh.

    Hope this helps some of you

  33. On 03 Jun 2018 at 04:19, Leonie Killeen said:

    Thanks Benji West that worked for me when nothing else would, I just made a new shop page and removed the old one – Much gratitude

  34. On 20 Jun 2018 at 02:30, Matt. K. said:

    Hello!!! I have been having the issue where my Woocommerce will not display any products, or even any products I try to create. I am using WC with Elementor pro, and every time I attempt to add products to a new section of the site, it appears as a thin grey bar with the WC logo in the middle. I have saved the permalinks, deactivated and deleted WC, and I have even gone as far as reinstalling the entire wordpress site because I am still at the very early stages of my website development. Any ideas?? I dont know what to do from this point

  35. On 09 Sep 2018 at 10:03, Ad said:

    my products are in wordpress “back-end” but not showing on my website unless i update each and every one. can’t bulk update, crashes the server. updating more than one at a time crashes the server. updating one at a time take 5 minutes. I’m on a powerful dedicated server so I assume it’s a software “woocommerce/woozone” issue that they aren’t able to solve.

  36. On 14 Sep 2018 at 00:14, Steve said:

    Thanks Benji that worked for me as well.
    Just made a new shop page in the page made sure the permalink was set corrently and removed the old one.
    Voila !

  37. On 23 Nov 2018 at 05:12, Sam Millard said:

    THANK YOU!!! This worked for me. Saved my butt after i uploaded a BUNCH of new products.

  38. On 20 Jan 2019 at 13:26, Nat said:

    THANK YOU! This worked for me after hours of scouring the web for a solution. So frustratingly simple! THANKS SO VERY MUCH – good karma coming your way!!

  39. On 27 Mar 2019 at 17:50, Neeraj Bhatia said:

    Hi, I am facing the same issue. I deleted Woocommerce plugin and then i deleted the pages, created by that plugin, thinking that when again i will install the plugin, the same pages will be created automatically and it should be not duplicated. But now when i have installed plugin, i can not see any of the page created by system, not even “Shop”, “Cart” or “My Account”.
    But i am able to create products and can see thru “view changes”, but honestly there is no pages, where shopping can be done from website. Please help me what to do now?

  40. On 05 Apr 2019 at 01:51, Scott Taylor said:

    One category works just fine. The others are setup the same way. No products show up…Did the permalinks fix, making a new shop page, and tried removing and re-adding. All was working fine until a few days ago. please help

  41. On 28 Jul 2019 at 22:51, Tashinga said:

    Thank you so much!!!!! I fond Jetpack to be the problem even if it was deactivated (don’t know why) so after removing it it worked!

  42. On 21 Aug 2019 at 11:43, Jayant Chaturvedi said:

    Thanks to the author. Bro its been very helpful. Much love from India.

  43. On 03 Sep 2019 at 18:17, Alina Belousova said:

    My problem is that my Shop only shows products from one category, but I need all of the existing products to be shown. Followed this advice and nothing changed.

  44. On 18 Jan 2020 at 14:29, Brenda Doucet said:

    Spent half an hour trying to figure out why my product page suddenly didn’t load. Followed your instructions and fixed the problem right away.

    Thank you

Add a Comment

If you have used this form and would like a copy of the information held about you on this website, or would like the information deleted, please email [email protected].